VOX Universal Beta: Bug Reports


#1

This topic is created to collect the most irritating scenarios, especially those when the VOX Universal app refuses to work properly!

When you experience an issue or something does not work as expected, send your feedback directly to the tech. support desk https://vox.rocks/support to have it sorted or post them here on this topic.

Once reporting, please provide insight into how you got the app to crash.
Include as much information about what you were doing around the time the app crashed.

The must-have information to be included in the report:

  • VOX Universal version
  • Operating System version
  • An e-mail associated with your VOX Account (optional)
  • Audio files formats if the problem is related to Playback or Upload (optional)
  • Include steps to reproduce if you think that they are necessary and aren’t obvious enough from the description of an issue. Always describe reproduction step by step.

And remember every little detail can be helpful to fix the problem!


#2

Have been trying the new Universal version (0.7.3b) on my Macbook pro (MacOS Big Sur) for the last couple of days. Seems pretty stable. Sometimes there is some playback stuttering but no crashes. I have noticed that the playback stops when the laptop goes to sleep. That doesn’t happen with the official version. What I like the most is how album loading is way much faster then in the official Vox version. By the way I am not sure if the old version support has been discontinued now that we have a new Universal app.
Great job and keep the new updates coming!

Best,

Ivica


#3

Can you play FLAC files via the new Universal app? I’m on latest macOS Catalina and can’t play FLAC files or mp3 on the new app. Old app still works great so I’ll be using that until the beta issues are fixed.


#4

Yes, Flac files play fine except when my laptop goes to sleep in which case the playback stops. The old app is driving me crazy as it’s becoming increasingly slow to do anything (loading albums, search, uploading etc) but still plays Ok.


#5

Thanks for reporting!

Please advise if the problem is still there?

May I ask you to share some additional details with our tech. support desk https://vox.rocks/support or here:

  • What VOX Universal + OS versions are you on? Windows or macOS?
  • What e-mail is associated with your VOX account?
  • Which Albums are displaying incorrectly? Please share the Album name (by Artist)

We will try to reproduce thing happening in our test conditions and get it fixed.


#6

Unfortunately the playback issue still exists with the new Vox Universal 0.7.12. One issue is that playback frequently stops after first song in the Album View and always stops the moment my MacBook Pro (Big Sur 11.2.3) goes to sleep. It happens with any album and they are all FLACs.


#7

After the latest update, it seems I cannot play any YouTube links that I have added in a collection:

Using Vox Universal v0.7.12 on macOS Big Sur 11.2.3.


#8

Ok, the issue of playback stopping when computer goes to sleep is solved by unchecking “Prevent Computer from sleeping when display is off” and “Wake for Network Access”. Now the only really critical issue remaining with Universal 0.7.12 beta at least for me is frequent playback stream interruptions sometimes followed by Vox disconnecting from Air Play. It looks like a buffering issue, but the Mac version doesn’t do that on the same laptop. Hopefully the next version will solve this.
Mac Book Pro, Big Sur 11.3


#9

One more thing, please fix gapless playback. In the meantime, I have found myself using the new Universal version much more compared to the regular Mac version, which has become way too slow.


#10

I created a post about this on its own but thought it was important to post this issue on here so it can be considered while the new app is still in development…
——————————————————————————————————————————————————————————————

When viewing an Artist it is nice to view their Albums in chronological order either from most recent to oldest or vice-versa (I am happy with either one). However, electronic artist (especially) have many releases which fall under different categories, like Mixes / Singles / Remixes / etc.

It would be nice to organize these releases separate from (below) all full-length Albums + EPs . I have already provided these with the proper metadata using the SORT ALBUM tag, starting these tags with something like:

zzMix 2018 [Mix Title]

zzMix 2020 [Mix Title]

zzRemix 2017 [Remix Title]

zzSingle 2017 [Single Title]

I realize this would only work if Albums are organized by Title/Name vs Year, but I supposed I could also just add a SORT ALBUM tag to every release using the TYPE + DATE instead like so:

01 AlbumEP 20180211 [Album/EP Title]for an Album/EP released on Feb. 11 2018

02 SingleRemix 20081214 [Single/Remix Title]for a Single/Remix released on Dec. 14 2008

03 Mix 20140000 [Mix/Mixtape Title]for a Mix/Mixtape released in 2014

The point being… I am happy to do ANY OF THESE, as long as VOX can simply start using the SORT ALBUM , SORT ARTIST , etc. tags to simply override the official ARTIST / ALBUM names.


#11

VOX UNIVERSAL – SEARCH FEATURE

I feel we need to talk about the search functionality of the Universal Beta. In short, it is much LESS INTUITIVE than the current version of VOX…

As you can see in my screenshot comparison (above), searching for the term radio on the current version of VOX will give you any ARTIST/ALBUM/TRACK that has the search term in its name. However doing the same search on the Universal Beta will give you limited results based on if you enter the search from the ARTISTS, ALBUMS, or TRACKS tab.

It seems like a lot of the functionality of the Beta is being treats each of these tabs like separate entities. The ARTIST tab will only allow you to search for ARTIST names, and only allow you to edit metadata for ARTIST names, and so on for the ALBUMS and TRACKS tabs.

It would be much more intuitive to treat them all universally. I’m sure other testers will back me on this…


#12

I prefer the new search tbh. Being able to filter for artists/albums/tracks is much better.


#13

VOX Universal now crashes for me every time I try to launch. This is the data for the crashed thread on Big Sur:

Thread 14 Crashed:
0 com.coppertino.ReVOX 0x000000000489b6d3 git.vox.rocks/go/lib/v2/encoding.NewDecoder + 147
1 ??? 0x0000000000000011 0 + 17
2 com.coppertino.ReVOX 0x00000000048a0f49 git.vox.rocks/go/revox/pkg/meta.ParseCUE + 329
3 com.coppertino.ReVOX 0x000000000490c9d4 git.vox.rocks/go/revox/pkg/uploader.fileCUE + 372
4 com.coppertino.ReVOX 0x000000000490bcc5 git.vox.rocks/go/revox/pkg/uploader.(*Task).do + 3397
5 com.coppertino.ReVOX 0x000000000490ae16 git.vox.rocks/go/revox/pkg/uploader.(*Task).Do + 214
6 com.coppertino.ReVOX 0x00000000047d00cc git.vox.rocks/go/lib/v2/worker.(*Worker).start + 236
7 com.coppertino.ReVOX 0x00000000047cffa6 git.vox.rocks/go/lib/v2/worker.NewWorker.dwrap.3 + 38

No other thread looks like it tries to access git.vox.rocks

Is this a local issue or a server issue?


#14

Update:
If I turn off all my network connections to the Internet, VU launches and doesn’t crash. Of course, it can’t access my library and displays a red banner about not being able to retrieve certs, and then a blue banner that warns me I’m not connected to the Internet. As soon as I establish a network connection, VU crashes.

NB: I got the new version 0.8.17 to run for a little while after not having any version installed for a while, but as soon as I tried to upload some individual .dsf files, the crashing started again. I’m uploading the rest of the .dsf files that may be stuck in the queue using the Mac VOX app. If VU starts working again after that, then I will have isolated my issue to .dsf files.


#15

Update:
It’s definitely the .dsf files (with or without a .cue file). I can upload .flac, .m4a all day long with no issues. However, as soon as I try to upload .dsf files, whether individually, as a selection or a whole folder, VU crashes.

I tried several things to get VU to launch after that without crashing. The problem is that the .dsf files are stuck in the upload queue with no easy or straightforward way to remove them from the queue. If you launch VU while connected to the Internet with .dsf files in the queue, it will immediately crash.

The simplest way to get VU working again seems to be to launch VU when no Internet connection is available. The app launches and doesn’t crash, but you do get the two warning banners I described in my previous post. Dismiss them. Then go to the Settings screen and visually locate the “Sign Out” button. You will need to be very quick with hand/eye coordination for this next step. Re-connect your computer to the Internet and simultaneously (or near as you can do) click the Sign Out button. Hopefully you can get VU to sign you out of your VOX account before it crashes. If you are successfully able to sign out, then VU will not crash. Quit VOX Universe.

Now that you’re signed out, VU clears out your upload queue. Sign in again and VU should return to normal operation. Don’t try to upload .dsf files and VU should work as expected.


Vox Universal latest (0.8.x) won't start
#16

Thanks for your post!

May we ask you to provide our tech.support: support@coppertino.com with some music files to reproduce this happening?