Songs / Albums uploading as "Unknown Artist / Unknown Album'


Is anyone else experiencing this issue?

Since Friday 17/09 when I am uploading a song or an album, they are uploading as "Unknown Artist / Unknown Album’. I have reached out to support but heard nothing back as of yet.

Tracks are all tagged correctly.



Thanks for your post!

Please share some details:

  • What VOX + OS versions are you on?
  • What are the file formats? Are you using the .cue file to deliver the meta?



I’m on latest VOX player 3.4.2 and MacOS Big Sur 11.6.

This happens for both FLAC and WAV but won’t happen with every track. Some files upload OK and some go to ‘Unknown Artist / Unknown Album’.

If I delete and keep forcing the upload eventually they go through OK but I’ve never had this issue previously. Have also tried re-installing VOX player.


I would appreciate a reply here please the issue is still not resolved


Yes, this has been happening to me as well. It first started a few weeks ago, and then started happening again today. It’s happening even though all the FLAC files are tagged and is extremely annoying.


Yes I still have the same problem. I’ve provided support a few files to test but this isn’t an issue with the files. I’m awaiting a response. I’ll let you know if I come up with a fix. It seems to eventually work if you delete the incorrect upload and try again (although it can take several attempts!!) but yes very annoying


I have had similar issues during the last few days.
I have uploaded several albums using Google Chrome in Incognito mode. All tracks are visible in the web interface after the uploads are completed and the browser window is refreshed.
However, some tracks are missing from several albums both in the VOX Player for Mac and in the iOS App. The tracks are not visible in artist view, album view or track view.
I can see and play the missing tracks if I do a search in the iOS player app. However, the tracks are not associated with an album, which seems to be the reason for them not appearing in artist view, album view or track view. Therefore, I’m not able to delete the tracks in VOX Player, since the tracks are not associated with an album.
I upload my music in FLAC format lever 5 using MediaHuman Converter, so the files are newly tagged and not messed up with any third party tagging software. I have used the same setup for months wit no problems.


We need updates here please. I’m still having these problems


Still no support here lol it’s now laughable


Thanks for your posts!

We investigate this happening hence, can`t reporoduce it yet.

May we ask to provide our with some example files, so we could do some testing?


No. I’ve already done this and is not specific to any particular file. There are other people with the same issue so you need to investigate it and resolve ASAP. I have several ongoing emails with support / Viktor and no resolutions. Extremely disappointed in VOX support


OK, if you’ve already shared the files, I am sure you will get an update on this soon.

However, we need to collect some more details, which might be helpful in reproducing this and getting it fixed.

Does it happen when you upload new tracks using VOX Universal (beta), VOX Uploader (beta),
VOX Music Player for macOS, or web-upload tools?
Have you noticed any errors during the upload?
How many files are there in the upload queue when it happens?




It happens with tracks using all upload options, I’ve tried every one. VOX Universal (beta), VOX Uploader (beta), VOX Music Player for macOS, and web-upload tools.

Some tracks will be fine and some will show up, then disappear, and some just won’t appear at all. If I force the upload by trying again several times it will eventually work but obviously the service is not working as it should. I have provided error logs to the support team previously. This happens when uploading a single track or multiple so doesn’t seem to be an issue with how many songs are in the queue.

Albums will sometimes upload only some of the songs as well, I have to repeat the process to get all songs uploaded.


Still no update from support


Same problem here!
No answer 1 week ago from the support!

Does it happen when you upload new tracks using VOX Universal (beta), VOX Uploader (beta),
VOX Music Player for macOS, or web-upload tools?
Have you noticed any errors during the upload?

These questions are asked and the support is simply disappears.

The support has no idea what is going on with their own software.

This is a FULL CHAOS !


It was working perfectly up until a few months ago. It’s been chaos since then.

I will be devastated if this is a scam we deserve answers!


I’ve shared tracks numerous times and provides further info and have yet to hear back from support? This is borderline outrageously bad service at this stage. Laughable


With this attitude they lose potential paying customers.


I have now received a Delivery Status Notification (Failure) when emailing support…what is going on!!!


Try uploading the troublesome files with a .cue file. That has worked for me on all .dsf albums and on some difficult .flac albums.

NB: You will have to create your own .cue file.