Can't normally install VOX Media Buttons [Solved]


Hi. I’m using VOX on my 3 macs and everything is great on them. I mean, after installing VOX for itself, I’ve installing VOX Media Buttons extension and when it’s asking me to give the permission in Accessibility, I say yes and that’s all. In the appropriate windows I see “VOX Media Buttons”, checked box near and it start’s to use that hardware keys to control the player.
Need to say, that all that macs has been updated to the newest version of the OS (Mojave and High Sierra) and everything works just fine.
But. Recently I bought new mac which had already Mojave on board. As usual, I’ve install VOX and then start to install VOX Preferences.prefPane
When it’s asking me to give the permission in System settings, I say yes but nothing happens - it’s just opens related windows for Accessibility but VOX Media Buttons is not in the list.
Reinstall did nothing, it’s saying, that I have already installed that pane - it’s confirmed by the icon of VOX Preferences in System settings that, by the way, opens self settings.
Deleting and reinstalling did nothing too. So, how can I install that VOX extension?

So, if I even turn off the restriction of making any changes in the Security & Privacy (clicking on lock) and then on the Privacy tab I’ll try to manually add VOX Media Buttons (go to username/Library/PreferencePanes/ -> then by the right clicking and taping to show the content of the package ->Contents/MacOS/ and try to add VOXHelper or VOX Preferences) nothing happens too, it doesn’t add any of these files to the list so I’m unable give the permission to VOX for exlusively use of media buttons.



Thanks for notification.

Please share an exact macOS version, so we can try to reproduce this happening.
Do the VOX Preferences icon appear in the System Preferences, like it was on other devices?


Current version of macOS Mojave is 10.14.1 and yes - VOX Preferences icon appear in the System Preferences.

I’m still trying to figure out what’s goes wrong with that regular installation of the VOX Preferences.

Digging in the direction of access settings, I found that for some reason I can’t add a single program to the list of programs that are allowed to access computer control (Security & Privacy -> Privacy -> Accessibility) . Need to say, the same version of the OS and the same antivirus (which I disabled for the next installation attempts) are installed on other computers and everything was ok, when I installed VOX Player and VOX Preferences on them.

Next, I learned that the list of apps and the saved settings for access to system management for them are stored in a database called “TCC.db”
Maybe I’m wrong, but as I understand it, if a program was installed for one user, then the access control parameter for the system accessibility for this program is stored in “username/Library/Application Support/”
And If this program was installed for all users, then a similar database file is stored in “Library/Application Support/”

Having opened these databases one by one, I of course found that there are no corresponding records regarding to VOX.

Then I decided to view the contents of these databases on other computers where the player and the preferences is installed and working normally. There I discovered that the user’s database file also does not have a similar record, but the database file for the entire system contains them! In the records, among other things, such entries were “service: kTCCServiceAccessibility client: com.coppertino.Vox-Helper allowed: 1” and “service: kTCCServicePostEvent client: com.coppertino.Vox-Helper allowed: 1”.
Accordingly, only the “system” has read and write access to these files, in the case of TCC.db in Library/Application Support/ and only the “username”, in the case of TCC.db in username/Library/Application Support/

For now I don’t even know why I can’t add any program to the Accessibility list to give it access to computer management. Well, now it’s clear that if I cannot manually do this, then the preference itself cannot do it all the more.



Thanks a lot for your report! It is passed to our

Hopefully, the new version of VOX: Preferences will be released soon.

Stay tuned.


Thx for reply, but I think it’s some kind of problem with system settings, 'cause any(!) program can’t add itself to that macOS Accessibility list and I, as admin user, can’t do this manually too.


So, the problem is solved! The reason, as I suspected, was in the antivirus, which blocked the ability to make any changes to the system settings.
Tellingly, ESET Cyber Security, which I have installed on MacBook Air (Mid 2011) with High Sierra, on MacBook Air (2017) with Mojave and iMac 2017 with Mojave too, does not create any restrictions for making such changes. But ESET Cyber Security Pro, which, as an addition, has a built-in firewall, on the MacBook Air 2018 with Mojave completely restricts the access of programs and the user to make changes to the system.
As a result, removing the antivirus solved the problem - the installation of VoxPrefs was successful and now everything works as it should.



Thanks for getting back to us! We really appreciate all information posted here, believe it will be useful for users.

Have a merry Christmas and a Happy New Year :slight_smile:



We got some good news - VOX Media Buttons app has a fresh update avaliable!

Go to “System Preferences” > “VOX Preferences” and press Check for Updates!


When attempting to use VOX Media Buttons while Vox is playing an audio file and hitting || (pause) key, a rainbow wheel will appear and Vox will stop responding. macOS 10.14.2 here.



Can you please indicate VOX app and VOX Media Buttons versions?
What Apple device do you have there?

Tip - You can check your current VOX Media Buttons version here: “System Preferences” > “VOX Preferences”, press Check for Updates!

We suggest updating to the most current version 1.5


Thanks for your response. Both are latest version:

Vox Music Player 3.3.7
Vox Preferences 1.5

Thing is, if I pause a track in Vox, it pauses normally. If I pause a track in the macOS top menu bar using the || button, or just use any of those other controls (prev/next/pause/play), a rainbow wheel would spin indefinitely and Vox will stop responding until I “force quit” it.



Seems to be an interesting case. Is it possible for you to reproduce this happening?
If yes, great! We will be glad to collect logs and pass it to the developers, so they could proceed with a fix!

How to do that:

  1. Quit VOX by cmd+Q (if launched)
  2. Open Console
    (find it through Terminal: open Terminal by control+Space > put “Console” > open Console)
  3. Click on Console Log (sidebar)
  4. Hit “Clear Display” at Console bar
  5. Launch VOX
  6. Try to reproduce that crash/issue
  7. Wait for ~1 min. to accumulate logs
  8. Copy everything in Console (Command+A)
  9. Save in text editor and send us saved file

You can find more details here:

Thanks for your help!