Bluetooth gapless playback bug on iOS with 48khz formats


I’ve tried my best to narrow down the case:

Gapless playback doesn’t work with OPUS files when playing via Bluetooth device (and that device is not Airpods)
UPDATE. I did some more testing and found out that the problem lies in 48khz sampling and not in OPUS, it’s just a coincidence that OPUS is 48khz-only, so is affected as well. I tested 44.1 AAC — it worked fine, i tested 48k FLAC — it also failed. So my current workaround is to (a) not use OPUS (b) resample my music to 44.1

So i tested several cases:

  1. MP3 44.1khz files — gapless works fine both via iPhone speaker and via Bluetooth
  2. OPUS 48khz files — gapless works fine via iPhone speaker, but for Bluetooth devices a very much audible gap (200–300 ms) is heard between tracks. Tested on two devices (Fiio BTR5, Plantronics Backbeat Pro 2)
  3. When using Airpods Pro (and I assume the usual Airpods as well, but haven’t been able to test), strangely OPUS 48khz works fine via Bluetooth as well. But that might be some special Apple magic :slight_smile:
  4. Wanted to test whether it’s Apple bug so used another player app (Foobar for iOS) to test the same files — both MP3 44.1khz and OPUS 48khz worked fine even via bluetooth. So I conclude it‘s a VOX bug

Files used for testing:

iPhone 11, occurs in both the latest VOX store version + latest beta from TestFlight