Why the media buttons in Mac can't control VOX but iTunes


#1

I have read the article ‘How to use Mac’s Media Buttons to control VOX’ and I have downloaded VOX Preferences panel, which are suppose to allow me play/pause the songs with the buttons not iTunes.

There are some shortcuts, such as space to play/pause, but it only work when VOX is shown on screen. It is so inconvenient!

I have been using VOX for years, and nothing wired happened until I bought a new laptop. I’ve tried whole day to make it work, hopefully someone can help me to solve this problem as soon as possible.

Cheers


#2

Hi,

Thanks for contacting us.

I am sure you tried it, but I should ask if all checkboxes are flagged?

Try to un-flag them all, restart VOX:Preferences and flag them all again.


#3

Hi,

Thank you for your reply, but it is not working at all. Is there any other solutions?


#4

I have those buttons checked and pressing play still opens itunes instead of playing on Vox.


#5

Hi,

We would suggest doing the following:

  • Make sure you are running the most recent version of VOX Preferences
  • Close VOX and iTunes
  • Go to VOX Preferences
  • Try to un-flag and then flag them again.
  • Start VOX

Use Mac’s Media Buttons to control VOX.

If no use, please try to re-install the most recent version of VOX Preferences from scratch.

Here is a download link: https://vox.rocks/mac-music-player/control-extension-download


#6

Tried everything mentioned (and more). still doesn’t work.


#7

Thanks for your post!

Have you also checked an “Input Monitoring”?

We would also suggest doing the following:

  • Close VOX
  • Go to System Preferences > VOX Preferences
  • Unflag all checkboxes and flag them again, start VOX app, check if Media Buttons are operating?

I am looking forward to hearing about your results!