Vox Uploader on macOS fails to upload with "all SubConns are in TransientFailure" error


Upload fails with “Rpc error: code = Unavailable desc = all SubConns are in TransientFailure”

See screenshot below:

Thank you for your help!


Im getting the same error. Looks like a new error as it was working the other day


I have the same problem today (June 24, 2020). Was working fine last evening. Today not so much.
I have the same exact message. Have tried:
1.) Closing Vox from Preferences window and toolbar icon and restarting computer.
2.) Moving VOX Uploader to trash and re-downloading.

Nothing has worked.


Thanks for your posts!

We apologize for the temporary inconvenience.

Our dev.team currently updating the server-side and API in order to prepare everything to upcoming ReVOX (beta) release, your dev.team has been already informed about the problems with VOX Uploader (beta), hopefully, they will bring it back to life in the shortest time possible.

In meantime, we suggest using web-upload tools and VOX Music Player for macOS for upload purposes.


When I use the web-upload tools, the album artwork will not upload. So, with the Vox Uploader tool not working, there is no way to currently upload music from my PC with artwork. And, since I don’t have a Mac, i don’t have any way to remove these bad uploads!


The problem I have with the web uploader is that the Artist name gets repeated. It happens every time!


I even had a look at the tags and I can’t see what’s causing it and the VOX app is so slow at uploading


Delete functionality on PC will be introduced in a ReVOX app, you can also delete your music from VOX Cloud using a macOS device running VOX Music Player for macOS.

Otherwise, please reach our tech. support desk https://vox.rocks/support and provide them with a list of the bad uploads to be deleted.


Can you please take a screenshot of what are you referring to?


Listen just fix your shit! This has been going on for weeks now! This is unacceptable for a paid service! Can’t act support get a run around shit uploads/doesn’t upload, missing artwork? This is utter garbage. To say my experience has been lack luster at best is an understatement.


Strongly agree with mike1, I’m still getting this same error, it’s been weeks!


These issues should be already fixed in the most recent version.

Please make sure you are using the most current version of the VOX Uploader 3.0.

You can also remove your current version of the VOX Uploader and download the newest VOX Uploader build with a fix from here: https://vox.rocks/blog/vox-music-uploader


in order to prepare everything to upcoming ReVOX (beta) release,

Been waiting a Loooong time for this


its just complete Junk, end of story, never ending issues.

Good riddance. I have successfully been able to get Cloudbeats+pcloud and also cloudmusic+pcloud working very nicely for carplay.

Vox is a waste of time.