VOX gone bonkers


Series of problems manifested themselves last night:

  1. App says “uploading music” - been doing that non-stop since late last evening (so that’s about 20 hours straight now)

  2. If I DO try to upload songs the app will not let me

  3. Preferences say “library unavailable” “0 bytes” yet I’m actually playing a song from my library (cloud, not off stored on computer) as I type this

  4. OMIT

  5. I’ve logged out and signed back in

  6. I’ve rebooted my computer (MacBook Pro, 2017 15")

  7. I’ve deleted and reinstalled

  8. When I open the VOX icon in my Apple Menu it says “synching with server” and when I select “cancel uploading” it asks me “Do you really want to cancel uploading 0 files?” If I hit cancel uploading it continues to upload an imaginary file (?)

Any ideas as to what’s happening?

EDIT to say I tried to navigate to the support page of web site but it won’t load for me right now. Sigh…



Thanks for getting in touch here!

We will check what has gone wrong and come back with an update.

Did you try to reach our support desk from here: https://vox.rocks/support?


I’m having this same difficulty in 2023. I’ve tried re-installing the app (MacOS version) even. It still hangs trying to to upload zero files! When I cancel upload, the “Uploading your music…” message does disappear… but only for a few seconds. :frowning:


Me too, same issue. Cannot upload new files, get exactly the same problem. Also cannot play music without endless buffering and stalling. Wrote to support a few days ago and then again today, heard nothing, no reply.