Unable to login to IPhone App-New Account


Try as I might I cannot use my credentials created on my Mac to login to the IOS version of the app. I have reset the password twice, installed and uninstalled the app, and also attempted to create the account again (successfully unsuccessful as it prompted correctly that I have already created the account).

And yes I am typing the credentials in correctly.



Thanks for your post. We’ve passed your request to QA and checked login on iOS and macOS devices and it is working fine with your account.

Please advise what can you see on the screen, when you try to login but fail? Any error?

Also, we would suggest trying to change your password to completely different one or using SSO (since you have Google mail associated with VOX app) with Google in VOX app for iOS.

Tell us how it goes?


I am having the same issue. I enter my credentials in the app to sign on - it does not give me any error but simply returns me to the login screen and will not log me in. I have successfully logged on to the app in OSX.



What VOX and iOS versions are you on?

I would try to do the following:

  • Close VOX app
  • Sign Out from your personal webpage: https://my.vox.rocks/account using Safari browser.
  • Start the VOX app
  • Go Settings > Account > Sign In


VOX app 2.3.11
iOS version 12.2

Did what you suggested; no change in behavior.


I also tried responding to a support email but you flagged my response as spam and rejected it


Hello - problem solved. The issue was cookies were being blocked in safari. Once that was disabled I was able to log on.


Glad to hear you’ve beat it!

We are already investigating what causes such behaviour to get rid of this spam blocker, if it happens again, please try contacting us once again, here: https://vox.rocks/support here: https://www.facebook.com/voxapp/ or even here: https://twitter.com/Coppertino?lang=en

I also tried responding to a support email but you flagged my response as spam and rejected it