Streaming doesn't work


Just doesn’t work on Tuesday evening June 2.

Why not?

Music just loads eternally…this service is no good if music doesn’t stream reliably, and that is one complaint I have had the whole time I’ve used it over the last couple of years.

Using Catalina and latest iOS.


On this same subject reliable and consistent streaming is an area you really need to improve on. Other apps stream hi-res flawlessly over much weaker internet connections.

Why is streaming so slow?


Finally, does uploading to an account and trying to stream music from that account at. the same time (even on a different network) affect the streaming? It seems to…


It seems steaming uncompressed AIFF files is no issue but VOX seems to have streaming ALAC files.


Thanks for reporting!

May I ask you to name some particular tracks\albums that are loading slowly? We will check the corresponding servers to be OK!


ALAC files generally do not stream well at all. AIFF seems to stream without problem.


Hello. I’m having the same problem. For a bit more than two days now, I haven’t been able to play a track without problems. Most of my library is in ALAC, so I made a test uploading some FLACs but it has de exact same problem. So basically, I’m not able to play any track using your service. I’ve tried with albums I uploaded just a couple of days ago, and albums I uploaded years ago. Strangely, some tracks load almost instantly, while I get just a couple of seconds of most others, before the playback starts stuttering.

Fixing this problem will be much appreciated as with the quarantine, music is one of the things that keeps me sane.


Try converting an album to AIFF within iTunes and then reupload it. You’ll be amazed at how quickly the AIFF file streams.

Still no real answer as to why but I suspect it’s due it it being uncompressed. I suspect the unfolding has some affect on speed.


Can anyone explain why AIFF files stream with less buffering and more reliably than ALAC files, despite being a third larger in size? I would suggest this is something to do with the way Vox unpacks the files for playback…latest everything…


Yes, you are right. When that happens, it might be connected with the m4a container. VOX`s audio engine just likes FLACs, MP3s and AIFFs more!


This is very interesting. I will use AIFF for smoother streaming moving forward.