Radio Favorites Conflict


#1

I have VOX on my iPhone and my MAC. While I have no problems at all with the iPhone app, my MAC app recently presents a “Radio Favorites Conflict”. This advises that I 'already have Favorite stations in iCloud and they don’t match your local Favorites. Do you want to merge local and iCloud stations?" It presents two choices ’ Merge local and iCloud Favorite stations", and “Don’t sync Favorite stations with iCloud”.

Problem is the VOX MAC app hangs and I cannot select either.

Forcing a quit and relaunching does not clear the issue, it hangs.

As a result I can no longer use the VOX app for MAC.

Uninstalling, rebooting, and reinstalling does not clear the issue, it hangs.


#2

Thanks for reporting!

Our QA and dev. team will get it checked, if they will succeed reproducing this happening it will be fixed in the upcoming version!

In the meantime, please try to do the following:

Close VOX app, open the Terminal and paste the following commands:

launchctl remove com.coppertino.VOXCloud

Press enter.

/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user

Press enter. - this one takes time to be executed, please take a while.

rm -rf ~/Library/Containers/com.coppertino.VOXCloud

Press enter.

rm -rf ~/Library/Containers/com.coppertino.Vox/

Press enter.

killall -SIGTERM cfprefsd

Press enter

Start VOX app and check if the problem still persists.

If no use, try to launch the attached script from the link below:

https://www.dropbox.com/s/rvx1f6t00kk6ka4/ResetVox.zip?dl=0

  • Close VOX
  • Run the script
  • Choose to reset VOX preferences. (There will be other options to be reset, like, Collections and etc - be careful!)

Fresh install: If no use, I would advise using a 3d party app to delete VOX and do a clean install (to make sure there are no components left). You may try CleanMyMac or similar to do it!

After removing the VOX app, please check the following Cache folders to be clean!

~/Library/Containers/com.coppertino.Vox/Data/Library/Caches/AudioCache/
~/Library/Containers/com.coppertino.Vox/Data/Library/Caches/com.coppertino.Vox/

You may download the most current version of VOX from our web-site - https://vox.rocks/mac-music-player

Blockquote