Preferred output always forgotten


#1

I am using Vox on the latest Mac OS 10.13.6. It’s a Mac mini connected to an HDMI monitor. The Vox sound output default in the preferences is “same as system” and the system always uses the HDMI monitor. But every time I wake from sleep and start using Vox again, Vox uses the mini’s internal speaker as the output. It does not remember, ever, when I have set Vox to use HDMI or system default. It always goes to the internal speaker, which is the last thing I would want. How to fix this?


#2

Hi,

Does VOX still state to use “Same as System” output? Does your OS see an HDMI monitor output when it happens?

But every time I wake from sleep and start using Vox again, Vox uses the mini’s internal speaker as the output.

Please try deleting VOX app using CleanMyMac or similar and install the most recent version.

Looking forward to your feedback!


#3

It looks like I’m going to have to reinstall, which is a royal pain. Now, for the first time, I get this message when I try to play songs using either HDMI or System Default: Vox couldn’t use current output, Current device is locked by other application. Close other application using it or select other device in Vox. What the???


#4

I’m using the App Store version. Is there a better version?


#5

I reinstalled and will update here should the problems recur. Thanks.


#6

Same thing. I was playing music on HDMI. Vox prefs audio out is set to HDMI. Computer went to sleep. Woke it up, hit play, Vox played sound through the computer’s speaker instead of HDMI.


#7

So what now? Do I not deserve any follow up? I reinstalled as instructed, it did not fix the problem, 5 days ago, and reported here as requested. Crickets.


#8

Hi,

Thanks for notification.

I suggest using “Same as system” as default output option in VOX and setting HDMI as system’s default output. It should make VOX app remember “Same as system” choice after sleep or re-boot.

Please tell me if it helped.
Thanks!


#9

It does not remember same as system. I tried that before I ever made a support ticket and since the reinstall. Also, where is the history? I wanted to see which songs had already played but I can’t find it.


#10

I’ve had this issue for ages on both MacOS High Sierra and Mojave. The “System default” option doesn’t remain selected after some combination of waking from sleep and disconnecting my Bluetooth headphones. It usually switches to “Built-in Output”, although I’ve also had it switch to my external monitor before as well.

Perhaps it would be best to remove the auto-switching functionality? If somebody wants to select a different output option for Vox alone, that should probably be a manual operation. The auto-switching breaks convention.

All that said, I still love the simplicity of Vox and will continue to use it as my free player of choice. :slight_smile:


#11

Same here, how can I lock it at “System Default”?
I do not want it to ever change to something else.
Any help please?


#12

Hi,

We would like to do that and probably it will be improved in future updates.
Can you please share your current VOX version and the build? (“About VOX” and make a screenshot)

But what should happen when the output set as “System Default”, is no longer available?

From the other hand, the “Internal Speakers” are always there! :slight_smile:


#13

Howdy!

Same problem here: macOS 10.14.3, VOX 3.3.7 (Build 3370.1). The player continues to play through the internal Macbook speakers after headphones have been connected (AirPods Gen 1) with “same as system output” option set. Both manual option switching and application reboot can solve this, although in this case you will lose your current playlist history (another problem). Please consider these issues.

Anyway, thanks for the awesome player!


#14

Hi,

Yes, sure. We already got it on our TODOs.

Hope it would be fixed already in the next iteration of VOX app!