Login fails


When I click the login button on Vox, my browser is redirected to this address:


It repeatedly responds (after a delay) “Gateway timed out.”

Happens in Firefox, happens in Safari. I’d like to use your product, but having to re-log in so often (and having the log in fail so often) is tough.

iMac running HighSierra 10.13.6.
Firefox 91.0.2


Same issue. After clicking on the “Authorize” button in the “Do you want to authorize VOX?” browser window the message “You will be redirected to VOX in a few seconds” is displayed but no redirects to VOX.

MacBook Pro 2019 with macOS Catalina 10.15.7 & Mac App Store VOX 3.4.2

P.S. By the way, the login to the account on the site is successful.


We would suggest trying to use some Terminal commands to fix this.

These commands will wipe everything that, probably, could have gone wrong during the sync process and they should help to beat it.

Close the VOX app, open the Terminal and paste&execute the following commands:

launchctl remove com.coppertino.VOXCloud

Press enter.

/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user

Press enter. - this one takes time to be executed, please take a while.

rm -rf ~/Library/Containers/com.coppertino.VOXCloud/

Press enter.

killall -SIGTERM cfprefsd

Press enter

Start VOX, go to VOX> Preferences> Account and re-login with your personal VOX account.


Thanks for the reply @VOX_Support_Team. After performing all the actions, the permissions for 1Password in Safari were reset, the next boot after the restart was slower than usual, but VOX still does not authorized after trying to log in.

By the way, I have Tweetbot installed and if I understand correctly, authorization in it works the same way as in VOX, that is, through authorization in Safari, which probably transfers a certain “token” to Tweetbot. So, authorization in Tweetbot works successfully.

I don’t know if this will help. My authorization URL is https://my.vox.rocks/oauth/authorize?response_type=code&client_id=ca091e45e3282bcb6d9465ed7780c7bc&redirect_uri=com.coppertino.voxcloud://oauth&new_cabinet=1&mas=1


Hmmm… no more help? It looks as if the app developers have stopped developing the app and fixing bugs


Execute commands: one more command was added to these lists, it should totally wipe all connected to VOX app:

Close VOX app, open the Terminal and paste following commands:

launchctl remove com.coppertino.VOXCloud

Press enter.

/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user

Press enter. - this one takes time to be executed, please take a while.

rm -rf ~/Library/Containers/com.coppertino.VOXCloud/

Press enter.

rm -rf ~/Library/Containers/com.coppertino.Vox/

Press enter. (it was the new one!)

killall -SIGTERM cfprefsd

Press enter

If no use, we would suggest re-installing the VOX app.

Fresh install: Don`t hesitate to use a 3d party app to delete VOX and do a clean install (to make sure there are no components left). You may try CleanMyMac or similar to do it!

After removing the VOX app, please check the following Cache folders to be clean!


The most recent version of the VOX app can be downloaded from our website - https://vox.rocks/mac-music-player or in Mac AppStore https://itunes.apple.com/us/app/vox-music-player-soundcloud-streamer/id461369673?ls=1&mt=12


Thanks @VOX_Support_Team for the answer!

I did all the steps that you described, except that I did not find the
~/Library/Containers/com.coppertino.Vox/ folder and therefore could not check it. There was still a com.coppertino.VOXAgent folder that I deleted it before reinstalling latest version VOX from the site. Unfortunately, I still cannot log-in after installing the version VOX (I tried the version from the Mac App Store also). Maybe I can submit to you some log files? But I don’t know where to look for them.

P.S. By the way, why is it that when dragging a folder with music files to the application icon in the dock, the contents of the folder are not included in the playlist? However, individual files are included in the playlist when dragging.



Version 3.4.3 didn’t change anything. Authorization is still not possible


Same issue - VOX 3.4.4 and Monterey 12.1. Followed the instructions for uninstalling and reinstalling VOX. I can log in on the website, but I cannot sign in on the app. When I click the sign in button I am redirected to a website that asks me to click a button to authorize VOX - but the app never “authorizes”


Same here. Authorize fails for any device (Mac/iPad/iPhone)


Hi, Thanks for contacting us! Please reach our tech. support desk https://vox.rocks/support to have it sorted!


tech. support ???

Stop humiliating yourselves more!

Steal people’s money, citing a failing system/application!!


We’ve had some issues with the OAuth authorization a week ago, and started the maintenance to fix it.

Service should be fully operative at the moment. Do you have some difficulties with login at the moment?