Tried "old version" then opened new one and hangs upon start


#1

as it says, i recently found out about ver 2.8 and downloaded it, i opened the installer, then opened the app ( did not move to application folder. also latest vox was closed) i click agree on an itune thing (i dont know), then im in, then i played 2 musics to try eq but i realize i didnt really need it anyway, so i then wondererd how it looks compared to latest so i opened it, it kept loading (not responding), so then i panicked, deleted the old version installer and dmg, and force quit the latest vox and reopening it, it was still the same, then went to application folder and deleted vox through trash and reinstalled it, and it was still the same. is there a way to fix this? please send help ASAP

Date/Time: 2021-05-21 22:16:24 +0800
End time: 2021-05-21 22:16:25 +0800
OS Version: Mac OS X 10.14.6 (Build 18G4032)
Architecture: x86_64
Report Version: 28

Data Source: Stackshots
Shared Cache: 0x1b7b4000 1FCAD33C-47AC-3CD6-ACA5-0E0FD6934F4C

Command: VOX
Path: /Applications/VOX.app/Contents/MacOS/VOX
Identifier: com.coppertino.Vox
Version: 3.4 (3400.7)
PID: 1571

Event: hang
Duration: 1.09s
Steps: 11 (100ms sampling interval)

Hardware model: MacBookAir5,1
Active cpus: 4

Time Awake Since Boot: 8800s
Time Since Wake: 2500s

Fan speed: 2398 rpm

i dont know whats happening please send help T-T
edit: im gonna move to foobar for a while